Wallet 3.0.3 not working on Ubuntu 18.04

atlet

New member
Aug 28, 2018
13
6
3
#1
Hi,

I downloaded latest wallet from your site (genesis-3.0.3-ubuntu64), but when I run it I get the folowing error:

./genesis-qt: error while loading shared libraries: libboost_program_options.so.1.65.1: cannot open shared object file: No such file or directory

How can I fix this issue?

Tnx
 

ssowellsvt

Genesis Project Manager
Staff member
Jun 14, 2018
54
100
33
USA
genesisnetwork.io
#3
Open up a terminal and c/p the following

sudo apt-get install -y build-essential libtool autotools-dev automake pkg-config libssl-dev libevent-dev bsdmainutils python3 libb2-dev git curl libboost-all-dev
 

ssowellsvt

Genesis Project Manager
Staff member
Jun 14, 2018
54
100
33
USA
genesisnetwork.io
#4
static binaries (on linux) by nature are not considered secure. Also our current structure causes some issues when creating a static linked binary (we're working on it). Therefore, you need dynamic libraries :)
 

atlet

New member
Aug 28, 2018
13
6
3
#5
Ok, but now I get this error: ./genesis-qt: error while loading shared libraries: libdb_cxx-4.8.so: cannot open shared object file: No such file or directory

I installed it, but it's 5.3 version...
 

ssowellsvt

Genesis Project Manager
Staff member
Jun 14, 2018
54
100
33
USA
genesisnetwork.io
#6
gotcha. run line by line

Code:
sudo apt-get install software-properties-common
sudo add-apt-repository ppa:bitcoin/bitcoin
sudo apt-get update
sudo apt-get install libdb4.8-dev libdb4.8++-dev
 

atlet

New member
Aug 28, 2018
13
6
3
#9
No, if I run I get this error: Segmentation fault (core dumped)

Before that I have genesis-2.0.3-linux-x64....
 

ssowellsvt

Genesis Project Manager
Staff member
Jun 14, 2018
54
100
33
USA
genesisnetwork.io
#10
Okay. the reason is because the new version (3.x) uses transaction indexing which was needed for masternodes to function properly. you need to go to your genesis folder and go ahead and delete everything except your wallet.dat

Should be at ~/.genesis/main/